Hi,

The install fails because Eclipse 3.4 comes with Mylyn 3.0 installed. The desktop requires an earlier version, which cannot be installed because version 3.0 is already installed.

This is the output of the Eclipse Install dialogue box:

Cannot complete the request. See the details.
Eclipse FTP and WebDAV Support will be ignored because a newer version is already installed.
Mylyn Bridge: Eclipse IDE will be ignored because a newer version is already installed.
Mylyn Bridge: Java Development will be ignored because a newer version is already installed.
Mylyn Bridge: PDE, CVS and Ant will be ignored because a newer version is already installed.
Mylyn Connector: Bugzilla will be ignored because a newer version is already installed.
Mylyn Focused UI (Recommended) will be ignored because a newer version is already installed.
Mylyn Task List (Required) will be ignored because a newer version is already installed.
SFTP Plug-in will be ignored because a newer version is already installed.
Subclipse will be ignored because a newer version is already installed.
Subclipse Integration for Mylyn 2.x (Optional) will be ignored because a newer version is already installed.
Subversion Native Library Adapter (JavaHL) will be ignored because a newer version is already installed.
Target Management Terminal will be ignored because a newer version is already installed.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.monitor.core/[2.0.0,3.0.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[3.0.0,4.0.0)] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[2.0.0,3.0.0)] can be satisfied.


Can you tell me how I can install CollabNet Desktop Eclipse Edition on Eclipse 3.4?

 

Regards,

Harsha